De belangrijkste veranderingen in WordPress 4.8

Geen reacties
Tags:
Posted 16 jun 2017 in nieuws

Onlangs bracht WordPress haar nieuwste versie, WordPress 4.8, uit. Traditiegetrouw draagt ook deze editie de bijnaam van een jazzmuzikant, dit keer Bill Evans. Hoewel 4.8 minder spannende features dan 4.7 bevat, is dit hét moment om te updaten mocht je dat nog niet gedaan hebben. In dit artikel de belangrijkste nieuwe features op een rij.

Nieuwe features voor gebruikers

  • Nieuwe media-widgets

Widgets zijn in intuïtiever en gebruiksvriendelijker dan in voorgaande WordPress-versies. Dankzij de text-, image-, video-, en audiowidget hoeft een gebruiker geen HTML-code meer in te voeren voor dynamische content. Tekst is via een WYSIWYG-editor in te voegen en beeldmateriaal is eenvoudig up te loaden.

  • Link boundaries

Het updaten van een link ging voorheen niet altijd even makkelijk, maar met de nieuwe ‘link boundaries’ features gaat het nu iets eenvoudiger. Als je een link selecteert, geeft deze in het blauw de grenzen aan. Hierdoor kun je gemakkelijk een tekst toevoegen aan het begin of eind van de link. Wat misschien een kleine toevoeging lijkt, is iets wat WordPress uiteindelijk nog intuïtiever maakt dan het al is, zo lijkt het.

  • Dichtstbijzijnde WordPress-meetups

In 4.8 krijg je in het dashboard te zien waar de dichtstbijzijnde WordPress-bijeenkomsten zijn. Helaas dit jaar geen landelijke WordCamp maar mogelijk vindt er wel een event plaats bij jou in de buurt. Vanaf nu kan je dat dus handig zien en bijhouden vanuit het dashboard.

Onder de motorkap

Onder de motorkap zijn er ook een paar kleine veranderingen gedaan in WordPress 4.8.

  • Customizer is responsive geworden

De Customizer van WordPress is responsive geworden. Het schalen van de Customizer feature gebeurt nu op basis van percentages in plaats van pixels, waardoor het beter en scherper op grotere (retina) schermen te zien is.

  • Core support voor WMA en WMV-file formats verdwijnt

WordPress 4.8 zal geen ondersteuning meer bieden aan WMA en WMV-file formats. Deze werden in voorgaande versies gebruikt voor het embedden van bijvoorbeeld Silverlight-toepassingen.

  • Veranderingen in de editor API

Er is een nieuwe API voor de TinyMCE editor. Daarmee kan de editor dynamischer samenwerken via JavaScript.

Upgraden voor betere veiligheid

Is je versie ouder dan of gelijk aan versie 4.7 of versie 4.7.1? Dan is het hoe dan ook verstandig op te updaten naar versie 4.8. In WordPress-versies 4.7 en 4.7.1 zat namelijk een kwetsbaarheid verstopt waarmee kwaadwillenden via contentmodules de WordPress-website konden infecteren. Updaten naar de nieuwste versie bied je dus wat extra veiligheid.

Overigens kun je ook andere dingen inregelen om WordPress veilig te houden. Lees de tips van onze servicemanager Arne Coomans om WordPress veilig te houden.

*) Dit artikel is tevens gepubliceerd op de website van True.nl



Lees het volledige bericht op Emerce »


Add Your Comment